Quantcast

Eclipse 3.6: Associate with Sonar... GroupId, ArtifactId empty for existing project

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Eclipse 3.6: Associate with Sonar... GroupId, ArtifactId empty for existing project

Raphael Bossek-3
Hi folks,

within Eclipse 3.6 Helios and Sonar 1.0.0.201011251615 Eclipse plugin
(and running Sonar 2.4.1 server) I intent to "Associate with Sonar..."
and see the name of my current Eclipse project but not the projects on
the server (connected with). GroupId, ArtifactId and Branch are empty
too and I've to enter the first two manually to continue.

Is the "Associate with Sonar..." issue normal or does it occur only on
my system ?

I've done the next step and entered the GroupId and ArtifactId (in the
same way as my Maven3 project is named). And could connect to Sonar. I
see the warnings marked with tags on the left for each line.

I've fixed this Sonar warnings manual, rebuild the project
(sonar-maven3-plugin is started) and the warnings disappear. Verified
by the web interface at http://localhost:9000.

The problem is that the tags do not disappear from the source code
view in Eclipse 3.6. Can someone confirm that ?

Greetings,
Raphael

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Eclipse 3.6: Associate with Sonar... GroupId, ArtifactId empty for existing project

Freddy Mallet SonarSource
Hello Raphaël,

within Eclipse 3.6 Helios and Sonar 1.0.0.201011251615 Eclipse plugin
(and running Sonar 2.4.1 server) I intent to "Associate with Sonar..."
and see the name of my current Eclipse project but not the projects on
the server (connected with). GroupId, ArtifactId and Branch are empty
too and I've to enter the first two manually to continue.

In fact, by using the button "Find on server", groupId and artifactId columns should be automatically filled :



I've fixed this Sonar warnings manual, rebuild the project
(sonar-maven3-plugin is started) and the warnings disappear. Verified
by the web interface at http://localhost:9000.

The problem is that the tags do not disappear from the source code
view in Eclipse 3.6. Can someone confirm that ?

You need to manually refresh the list of Sonar violations by using the refresh button in the "Violations" view :


Kind regards,

Freddy

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Eclipse 3.6: Associate with Sonar... GroupId, ArtifactId empty for existing project

Raphael Bossek-3
2010/12/5 Freddy Mallet <[hidden email]>:

> Hello Raphaël,
>>
>> within Eclipse 3.6 Helios and Sonar 1.0.0.201011251615 Eclipse plugin
>> (and running Sonar 2.4.1 server) I intent to "Associate with Sonar..."
>> and see the name of my current Eclipse project but not the projects on
>> the server (connected with). GroupId, ArtifactId and Branch are empty
>> too and I've to enter the first two manually to continue.
>
> In fact, by using the button "Find on server", groupId and artifactId
> columns should be automatically filled :
> http://docs.codehaus.org/download/attachments/186712286/sonar-link-eclipse-projects.png?version=1&modificationDate=1290594161476

I'm sorry, this is not the case for me. I suggests that the server
respond the project, groupId and artifactId but where is this
information from ? Do I have to set something in my MANIFEST.MF ? Do I
have to configure the sonar-maven3-plugin:2.4.1 plugin ?

Greetings,
Raphael

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Eclipse 3.6: Associate with Sonar... GroupId, ArtifactId empty for existing project

Jérémie-6
In reply to this post by Raphael Bossek-3
Hi Raphaël,

The groupId and artifactId are the key in your server sonar. For  
example for this project  
http://nemo.sonarsource.org/dashboard/index/org.codehaus.sonar-plugins:sonar-flex-plugin?did=1 you  
have
Key : org.codehaus.sonar-plugins:sonar-flex-plugin

org.codehaus.sonar-plugins is the groupId and sonar-flex-plugin is the  
artifactId.

If you have an eclipse project with the same name as artifactId, the  
command should normally work.

What you should remember is the eclipse project must have the same  
name as the artifactId.

I hope this help.

Jérémie.




2010/12/6 Raphael Bossek <[hidden email]>:

> 2010/12/5 Freddy Mallet <[hidden email]>:
>> Hello Raphaël,
>>>
>>> within Eclipse 3.6 Helios and Sonar 1.0.0.201011251615 Eclipse plugin
>>> (and running Sonar 2.4.1 server) I intent to "Associate with Sonar..."
>>> and see the name of my current Eclipse project but not the projects on
>>> the server (connected with). GroupId, ArtifactId and Branch are empty
>>> too and I've to enter the first two manually to continue.
>>
>> In fact, by using the button "Find on server", groupId and artifactId
>> columns should be automatically filled :
>> http://docs.codehaus.org/download/attachments/186712286/sonar-link-eclipse-projects.png?version=1&modificationDate=1290594161476
>
> I'm sorry, this is not the case for me. I suggests that the server
> respond the project, groupId and artifactId but where is this
> information from ? Do I have to set something in my MANIFEST.MF ? Do I
> have to configure the sonar-maven3-plugin:2.4.1 plugin ?
>
> Greetings,
> Raphael
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>
>


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Eclipse 3.6: Associate with Sonar... GroupId, ArtifactId empty for existing project

Raphael Bossek-3
Hi Jérémie,

the last tip was the solution. Great.

Greetings,
Raphael

2010/12/6 Jérémie <[hidden email]>:

> Hi Raphaël,
>
> The groupId and artifactId are the key in your server sonar. For example for
> this project
> http://nemo.sonarsource.org/dashboard/index/org.codehaus.sonar-plugins:sonar-flex-plugin?did=1
> you have
> Key : org.codehaus.sonar-plugins:sonar-flex-plugin
>
> org.codehaus.sonar-plugins is the groupId and sonar-flex-plugin is the
> artifactId.
>
> If you have an eclipse project with the same name as artifactId, the command
> should normally work.
>
> What you should remember is the eclipse project must have the same name as
> the artifactId.
>
> I hope this help.
>
> Jérémie.
>
>
>
>
> 2010/12/6 Raphael Bossek <[hidden email]>:
>>
>> 2010/12/5 Freddy Mallet <[hidden email]>:
>>>
>>> Hello Raphaël,
>>>>
>>>> within Eclipse 3.6 Helios and Sonar 1.0.0.201011251615 Eclipse plugin
>>>> (and running Sonar 2.4.1 server) I intent to "Associate with Sonar..."
>>>> and see the name of my current Eclipse project but not the projects on
>>>> the server (connected with). GroupId, ArtifactId and Branch are empty
>>>> too and I've to enter the first two manually to continue.
>>>
>>> In fact, by using the button "Find on server", groupId and artifactId
>>> columns should be automatically filled :
>>>
>>> http://docs.codehaus.org/download/attachments/186712286/sonar-link-eclipse-projects.png?version=1&modificationDate=1290594161476
>>
>> I'm sorry, this is not the case for me. I suggests that the server
>> respond the project, groupId and artifactId but where is this
>> information from ? Do I have to set something in my MANIFEST.MF ? Do I
>> have to configure the sonar-maven3-plugin:2.4.1 plugin ?
>>
>> Greetings,
>> Raphael
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>   http://xircles.codehaus.org/manage_email
>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Eclipse 3.6: Associate with Sonar... GroupId, ArtifactId empty for existing project

Raghava
In reply to this post by Jérémie-6
Hi, I was installed sonar 3.2 and i was trying to configure the sonar in RAD 8(eclipse). I was install the sonar in eclipse successfuly . when i try to link my project to sonar server. even i enter group and artifactId,still get empty groupId error when to “Associate with sonar”. project 'vzw' with key 'test:vzw' not found on server Is there any specific format to do.. Thanks Raghava
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Eclipse 3.6: Associate with Sonar... GroupId, ArtifactId empty for existing project

Freddy Mallet
Hi Raghava, 

PLEASE don't reopen an old thread of discussions but just mention it in your email. 

Could you send two screenshots :
  • The "Associate with Sonar" window before clicking on the "Finish" button
  • And another one after
Thanks
Freddy

On Wed, Sep 5, 2012 at 1:55 PM, Raghava <[hidden email]> wrote:

Hi,

I was installed sonar 3.2 and i was trying to configure the sonar in RAD
8(eclipse).

I was install the sonar in eclipse successfuly . when i try to link my
project to sonar server.

even i enter group and artifactId,still get empty groupId error when to
“Associate with sonar”.

 project 'vzw' with key 'test:vzw' not found on server

Is there any specific format to do..

Thanks
Raghava



--
View this message in context: http://sonar.15.n6.nabble.com/Eclipse-3-6-Associate-with-Sonar-GroupId-ArtifactId-empty-for-existing-project-tp3200281p5002691.html
Sent from the Sonar user mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email



Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Eclipse 3.6: Associate with Sonar... GroupId, ArtifactId empty for existing project

David Gageot
Hi Raghava,

To associate a project with Sonar, you first have to analyse the project
outside of Eclipse. This way, the Sonar server will know your groupId/artifactId


David.

On 7 September 2012 15:47, Freddy Mallet <[hidden email]> wrote:
Hi Raghava, 

PLEASE don't reopen an old thread of discussions but just mention it in your email. 

Could you send two screenshots :
  • The "Associate with Sonar" window before clicking on the "Finish" button
  • And another one after
Thanks
Freddy

On Wed, Sep 5, 2012 at 1:55 PM, Raghava <[hidden email]> wrote:

Hi,

I was installed sonar 3.2 and i was trying to configure the sonar in RAD
8(eclipse).

I was install the sonar in eclipse successfuly . when i try to link my
project to sonar server.

even i enter group and artifactId,still get empty groupId error when to
“Associate with sonar”.

 project 'vzw' with key 'test:vzw' not found on server

Is there any specific format to do..

Thanks
Raghava



--
View this message in context: http://sonar.15.n6.nabble.com/Eclipse-3-6-Associate-with-Sonar-GroupId-ArtifactId-empty-for-existing-project-tp3200281p5002691.html
Sent from the Sonar user mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email






--
-- David
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Eclipse 3.6: Associate with Sonar... GroupId, ArtifactId empty for existing project

Raghava
Yes David ,

Sorry to reopen this topic again,the Yes i did the same way.

First time i analyzed the project outside the exclipse. I have given
the same groupId/artifactId which i analyzed out side the eclipse and
clicked on  "Find on server" button then Ok.

Then i associate the project, after i try to do on local analysis. but
not analyzed the project from exclipse. not showing any vilations and
mesure and hotspots.

The only thing is Web is showing metrics and violations.

Can you please give me the idea.

Sonar console it showing analyze successfully.
Registered 104 metrics
Registered repository squid/java with 12 rules
Registered repository pmd/java with 224 rules
Registered repository findbugs/java with 384 rules
Registered repository checkstyle/java with 122 rules
Selected quality profile : [name=VZW_V1,language=java]
Sensor JavaSourceImporter...
Sensor JavaSourceImporter done: 0 ms
Sensor SquidSensor...
Java Squid scan...
Java Squid scan done: 0 ms
Sensor SquidSensor done: 0 ms
Sensor CpdSensor...
Sensor CpdSensor done: 0 ms
Sensor ProfileSensor...
Sensor ProfileSensor done: 0 ms
Sensor VersionEventsSensor...
Sensor VersionEventsSensor done: 0 ms
Execute decorators...
ANALYSIS SUCCESSFUL

Thanks & Regards
Raghava




On 9/7/12, David Gageot [via Sonar]
<[hidden email]> wrote:

>
>
> Hi Raghava,
>
> To associate a project with Sonar, you first have to analyse the project
> outside of Eclipse. This way, the Sonar server will know your
> groupId/artifactId
>
> See http://jira.codehaus.org/browse/SONARIDE-212
>
> David.
>
> On 7 September 2012 15:47, Freddy Mallet <[hidden email]> wrote:
>
>> Hi Raghava,
>>
>> PLEASE don't reopen an old thread of discussions but just mention it in
>> your email.
>>
>> Could you send two screenshots :
>>
>>    - The "Associate with Sonar" window before clicking on the "Finish"
>>    button
>>    - And another one after
>>
>> Thanks
>> Freddy
>>
>> On Wed, Sep 5, 2012 at 1:55 PM, Raghava <[hidden email]> wrote:
>>
>>>
>>> Hi,
>>>
>>> I was installed sonar 3.2 and i was trying to configure the sonar in RAD
>>> 8(eclipse).
>>>
>>> I was install the sonar in eclipse successfuly . when i try to link my
>>> project to sonar server.
>>>
>>> even i enter group and artifactId,still get empty groupId error when to
>>> “Associate with sonar”.
>>>
>>>  project 'vzw' with key 'test:vzw' not found on server
>>>
>>> Is there any specific format to do..
>>>
>>> Thanks
>>> Raghava
>>>
>>>
>>>
>>> --
>>> View this message in context:
>>> http://sonar.15.n6.nabble.com/Eclipse-3-6-Associate-with-Sonar-GroupId-ArtifactId-empty-for-existing-project-tp3200281p5002691.html
>>> Sent from the Sonar user mailing list archive at Nabble.com.
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe from this list, please visit:
>>>
>>>     http://xircles.codehaus.org/manage_email
>>>
>>>
>>>
>>
>
>
> --
> -- David
>
>
>
>
> _______________________________________________
> If you reply to this email, your message will be added to the discussion
> below:
> http://sonar.15.n6.nabble.com/Eclipse-3-6-Associate-with-Sonar-GroupId-ArtifactId-empty-for-existing-project-tp3200281p5002804.html
>
> To unsubscribe from Eclipse 3.6: Associate with Sonar... GroupId, ArtifactId
> empty for existing project, visit
>
Regards
Raghava
09873919030
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Eclipse 3.6: Associate with Sonar... GroupId, ArtifactId empty for existing project

Raghava



Please update me?

Thanks & Regards
Raghava
Loading...