Quantcast

Is it possible to use 2 versions of plugin?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Is it possible to use 2 versions of plugin?

Bartłomiej Budz
Hi Sonar users

I'm using a tool to code coverage which crerates Emma compatible
output, but in Emma 2.0.5312 file format, which is compatible with old
1.0.1 Sonar Emma plugin.
New Sonar Emma Plugin (1.2.1) requires new EMMA 2.1.5320 format. On my
company Sonar server, it's actually 1.2.1 plugin version installed,
and there's no possibility to change it to old version, because many
projects are using new version.

So, I want to ask you, maybe you know:
Is there any way to use both versions of plugin?
Maybe somebody tried to do something similar?
Maybe I have just to change naming convention in old plugin version
from emma  to e.g. "oldemma"?
Will it work?

Thank in advance for your help.

Regards,
Bart

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Is it possible to use 2 versions of plugin?

David Racodon-2
Hi Bart,

Is there any way to use both versions of plugin?

No

 
Maybe I have just to change naming convention in old plugin version
from emma  to e.g. "oldemma"?
Will it work?

No


If I were you, I'd ask the projects to migrate to the newest version of Emma.
Is there anything that would prevent such a migration?

Thank you 

Regards,

David RACODON | SonarSource
Senior Consultant



On 13 August 2012 13:11, Bartłomiej Budz <[hidden email]> wrote:
Hi Sonar users

I'm using a tool to code coverage which crerates Emma compatible
output, but in Emma 2.0.5312 file format, which is compatible with old
1.0.1 Sonar Emma plugin.
New Sonar Emma Plugin (1.2.1) requires new EMMA 2.1.5320 format. On my
company Sonar server, it's actually 1.2.1 plugin version installed,
and there's no possibility to change it to old version, because many
projects are using new version.

So, I want to ask you, maybe you know:
Is there any way to use both versions of plugin?
Maybe somebody tried to do something similar?
Maybe I have just to change naming convention in old plugin version
from emma  to e.g. "oldemma"?
Will it work?

Thank in advance for your help.

Regards,
Bart

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email



Loading...