Quantcast

PMD 2.2 - dependency missing?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

PMD 2.2 - dependency missing?

Olivier Dehon-2
Hello,

I am new to Sonar, and I followed the clear and concise instructions on
the website to get it to run with no problem.

That said, I faced a few issues with the version of the PMD plugin that
is hard-coded in the Sonar plugin code (2.2).

Whenever Sonar was running the PMD report, it failed with a
NoClassDefFound error, and indeed, it looks like the
maven-pmd-plugin-2.2.pom lacks a dependency on backport-util-concurrent,
causing the NCDF error. I had to hack the pom in my local repository to
make it work.

It looks like version 2.3 of the PMD plugin solves that issue. Would it
be possible to update the Sonar plugin code to use version 2.3 instead?

Thanks in advance, -Olivier


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: PMD 2.2 - dependency missing?

Simon
Administrator
Hello Olivier,

Good news, sonar 1.1 will use the PMD plugin 2.3 (see http://jira.codehaus.org/browse/SONAR-64

Regards,
Simon

On Jan 20, 2008 3:28 PM, Olivier Dehon <[hidden email]> wrote:
Hello,

I am new to Sonar, and I followed the clear and concise instructions on
the website to get it to run with no problem.

That said, I faced a few issues with the version of the PMD plugin that
is hard-coded in the Sonar plugin code (2.2).

Whenever Sonar was running the PMD report, it failed with a
NoClassDefFound error, and indeed, it looks like the
maven-pmd-plugin-2.2.pom lacks a dependency on backport-util-concurrent,
causing the NCDF error. I had to hack the pom in my local repository to
make it work.

It looks like version 2.3 of the PMD plugin solves that issue. Would it
be possible to update the Sonar plugin code to use version 2.3 instead?

Thanks in advance, -Olivier


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email



Loading...