Quantcast

sonar 3.0 password encryption issue

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

sonar 3.0 password encryption issue

marathiboy
Hello,

I am using sonar 3.0 on RH, with mysql 5.1

Everything works fine, but now I want to encrypt mysql password in sonar.conf/. I followed the wiki documentation, and generated secret key. updated the 'sonar.secretKeyPath' in sonar.properties, restart sonar. Was able to encrypt the password using configuration page. However, when I paste this generated value to 'sonar.jdbc.password:' in sonar.properties, I get following exception on start-up, if I use plain text value everything still works.

Appreciate your response.
Regards,

M


INFO   | jvm 1    | 2012/08/13 18:56:11 | gem install jruby-openssl for full support.
INFO   | jvm 1    | 2012/08/13 18:56:13 | 2012-08-13 18:56:13.341:WARN:/:unable to create shared application instance
INFO   | jvm 1    | 2012/08/13 18:56:13 | org.jruby.rack.RackInitializationException: syntax error on line 4, col -1: `'|?from file:/opt/sonar-3.0/war/sonar-server/WEB-INF/lib/jruby-complete-1.6.1.jar!/META-INF/jruby.home/lib/ruby/1.8/yaml.rb:134:in `load'|?from /opt/sonar-3.0/war/sonar-server/WEB-INF/vendor/rails/railties/lib/initializer.rb:902:in `database_configuration'|?from /opt/sonar-3.0/war/sonar-server/WEB-INF/vendor/rails/railties/lib/initializer.rb:437:in `initialize_database'|?from /opt/sonar-3.0/war/sonar-server/WEB-INF/vendor/rails/railties/lib/initializer.rb:141:in `process'|?from org/jruby/RubyKernel.java:2052:in `send'|?from /opt/sonar-3.0/war/sonar-server/WEB-INF/vendor/rails/railties/lib/initializer.rb:113:in `run'|?from /opt/sonar-3.0/war/sonar-server/WEB-INF/config/environment.rb:23:in `(root)'|?from org/jruby/RubyKernel.java:1063:in `load'|?from /opt/sonar-3.0/war/sonar-server/WEB-INF/config/environment.rb:53:in `load_environment'|?from file:/opt/sonar-3.0/war/sonar-server/WEB-INF/lib/jruby-rack-1.0.0.1.jar!/jruby/rack/rails.rb:46:in `to_app'|?from file:/opt/sonar-3.0/war/sonar-server/WEB-INF/lib/jruby-rack-1.0.0.1.jar!/jruby/rack/rails.rb:191:in `new'|?from <script>:2:in `(root)'|?from org/jruby/RubyKernel.java:2021:in `instance_eval'|?from file:/opt/sonar-3.0/war/sonar-server/WEB-INF/lib/jruby-rack-1.0.0.1.jar!/vendor/rack-1.2.1/rack/builder.rb:46:in `initialize'|?from <script>:2:in `(root)'|
INFO   | jvm 1    | 2012/08/13 18:56:13 |       at org.jruby.rack.DefaultRackApplicationFactory$4.init(DefaultRackApplicationFactory.java:184)
INFO   | jvm 1    | 2012/08/13 18:56:13 |       at org.jruby.rack.DefaultRackApplicationFactory.getApplication(DefaultRackApplicationFactory.java:59)
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: sonar 3.0 password encryption issue

Simon Brandhof
Hi,

Are there non-letter characters in your encrypted password, except + and = ?

Thanks

On 13 August 2012 21:14, marathiboy <[hidden email]> wrote:
Hello,

I am using sonar 3.0 on RH, with mysql 5.1

Everything works fine, but now I want to encrypt mysql password in
sonar.conf/. I followed the wiki documentation, and generated secret key.
updated the 'sonar.secretKeyPath' in sonar.properties, restart sonar. Was
able to encrypt the password using configuration page. However, when I paste
this generated value to 'sonar.jdbc.password:' in sonar.properties, I get
following exception on start-up, if I use plain text value everything still
works.

Appreciate your response.
Regards,

M


INFO   | jvm 1    | 2012/08/13 18:56:11 | gem install jruby-openssl for full
support.
INFO   | jvm 1    | 2012/08/13 18:56:13 | 2012-08-13
18:56:13.341:WARN:/:unable to create shared application instance
INFO   | jvm 1    | 2012/08/13 18:56:13 |
org.jruby.rack.RackInitializationException: syntax error on line 4, col -1:
`'|?from
file:/opt/sonar-3.0/war/sonar-server/WEB-INF/lib/jruby-complete-1.6.1.jar!/META-INF/jruby.home/lib/ruby/1.8/yaml.rb:134:in
`load'|?from
/opt/sonar-3.0/war/sonar-server/WEB-INF/vendor/rails/railties/lib/initializer.rb:902:in
`database_configuration'|?from
/opt/sonar-3.0/war/sonar-server/WEB-INF/vendor/rails/railties/lib/initializer.rb:437:in
`initialize_database'|?from
/opt/sonar-3.0/war/sonar-server/WEB-INF/vendor/rails/railties/lib/initializer.rb:141:in
`process'|?from org/jruby/RubyKernel.java:2052:in `send'|?from
/opt/sonar-3.0/war/sonar-server/WEB-INF/vendor/rails/railties/lib/initializer.rb:113:in
`run'|?from
/opt/sonar-3.0/war/sonar-server/WEB-INF/config/environment.rb:23:in
`(root)'|?from org/jruby/RubyKernel.java:1063:in `load'|?from
/opt/sonar-3.0/war/sonar-server/WEB-INF/config/environment.rb:53:in
`load_environment'|?from
file:/opt/sonar-3.0/war/sonar-server/WEB-INF/lib/jruby-rack-1.0.0.1.jar!/jruby/rack/rails.rb:46:in
`to_app'|?from
file:/opt/sonar-3.0/war/sonar-server/WEB-INF/lib/jruby-rack-1.0.0.1.jar!/jruby/rack/rails.rb:191:in
`new'|?from <script>:2:in `(root)'|?from org/jruby/RubyKernel.java:2021:in
`instance_eval'|?from
file:/opt/sonar-3.0/war/sonar-server/WEB-INF/lib/jruby-rack-1.0.0.1.jar!/vendor/rack-1.2.1/rack/builder.rb:46:in
`initialize'|?from <script>:2:in `(root)'|
INFO   | jvm 1    | 2012/08/13 18:56:13 |       at
org.jruby.rack.DefaultRackApplicationFactory$4.init(DefaultRackApplicationFactory.java:184)
INFO   | jvm 1    | 2012/08/13 18:56:13 |       at
org.jruby.rack.DefaultRackApplicationFactory.getApplication(DefaultRackApplicationFactory.java:59)



--
View this message in context: http://sonar.15.n6.nabble.com/sonar-3-0-password-encryption-issue-tp5001930.html
Sent from the Sonar user mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email





--

Simon BRANDHOF | SonarSource
http://sonarsource.com

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: sonar 3.0 password encryption issue

marathiboy
Thanks for reply,

There are no non alphabet (letter) characters in password.

I tried to remove all plugins but that didn't work either. :-(

Thanks

M
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: sonar 3.0 password encryption issue

Simon Brandhof
Ok I found the issue : you're facing http://jira.codehaus.org/browse/SONAR-3448 that is fixed in versions 3.0.1 and 3.1.

On 13 August 2012 23:20, marathiboy <[hidden email]> wrote:
Thanks for reply,

There are no non alphabet (letter) characters in password.

I tried to remove all plugins but that didn't work either. :-(

Thanks

M



--
View this message in context: http://sonar.15.n6.nabble.com/sonar-3-0-password-encryption-issue-tp5001930p5001935.html
Sent from the Sonar user mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email





--

Simon BRANDHOF | SonarSource
http://sonarsource.com

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: sonar 3.0 password encryption issue

marathiboy
Yes that worked thanks..

I saw that issue and thought it was related to windows.

Thanks

M
Loading...