Quantcast

sonar-ant-task-1.4.jar + sonar v.3.1.1 -- BadDatabaseVersion

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

sonar-ant-task-1.4.jar + sonar v.3.1.1 -- BadDatabaseVersion

Parslow, Allen
Hi All,
I'm using sonar-ant-task-1.4.jar to perform analysis with sonar  v.3.1.

In the last few days after successful execution, I'm now getting the error:
Caused by: org.sonar.core.persistence.BadDatabaseVersion: Database must be upgraded. Please browse http://localhost:9000/setup

When I browse to that page I get:
- Database is up-to-date.

The log up to that point has:
 [sonar:sonar] Apache Ant(TM) version 1.8.3 compiled on February 26 2012
[sonar:sonar] Sonar Ant Task version: 1.4
[sonar:sonar] Loaded from: file:/var/lib/jenkins/jobs/XXXXXX/workspace/trunk/ XXXXXX /projectartifacts/ivy/ivylib/sonar/sonar-ant-task-1.4.jar
[sonar:sonar] Sonar work directory: /var/lib/jenkins/jobs/XXXXXX/workspace/trunk/XXXXXX/.sonar
[sonar:sonar] Sonar server: http://localhost:9000
[sonar:sonar] Sonar version: 3.1.1
[sonar:sonar] 08:50:41.325 INFO      o.s.c.p.Database - Create JDBC datasource to url jdbc:mysql://localhost:3306/sonar?useUnicode=true&characterEncoding=utf8&rewriteBatchedStatements=true

I cleaned the Jenkins workspace, afterwards I noticed that /.sonar/batch has files like the following in it:
sonar-core-3.2.jar

Does that mean the ant task is trying to analyze with Sonar v3.2?

Thanks,
Allen Parslow

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: sonar-ant-task-1.4.jar + sonar v.3.1.1 -- BadDatabaseVersion

Fabrice Bellingard-4
Hi Allen,

there's something wrong with the configuration of your project. Indeed, if you notice that you have "*-3.2" JAR files in the ".sonar/batch" folder, this means that the "sonar.host.url" property points to a Sonar 3.2 instance (there's no other way to have such JARs downloaded).

So you can have a look at the properties defined:
  • in your Jenkins instance
and/or 
  • in your Ant script


Best regards,

Fabrice BELLINGARD | SonarSource
http://sonarsource.com



On Tue, Sep 11, 2012 at 4:35 PM, Parslow, Allen <[hidden email]> wrote:
Hi All,
I'm using sonar-ant-task-1.4.jar to perform analysis with sonar  v.3.1.

In the last few days after successful execution, I'm now getting the error:
Caused by: org.sonar.core.persistence.BadDatabaseVersion: Database must be upgraded. Please browse http://localhost:9000/setup

When I browse to that page I get:
- Database is up-to-date.

The log up to that point has:
 [sonar:sonar] Apache Ant(TM) version 1.8.3 compiled on February 26 2012
[sonar:sonar] Sonar Ant Task version: 1.4
[sonar:sonar] Loaded from: file:/var/lib/jenkins/jobs/XXXXXX/workspace/trunk/ XXXXXX /projectartifacts/ivy/ivylib/sonar/sonar-ant-task-1.4.jar
[sonar:sonar] Sonar work directory: /var/lib/jenkins/jobs/XXXXXX/workspace/trunk/XXXXXX/.sonar
[sonar:sonar] Sonar server: http://localhost:9000
[sonar:sonar] Sonar version: 3.1.1
[sonar:sonar] 08:50:41.325 INFO      o.s.c.p.Database - Create JDBC datasource to url jdbc:mysql://localhost:3306/sonar?useUnicode=true&characterEncoding=utf8&rewriteBatchedStatements=true

I cleaned the Jenkins workspace, afterwards I noticed that /.sonar/batch has files like the following in it:
sonar-core-3.2.jar

Does that mean the ant task is trying to analyze with Sonar v3.2?

Thanks,
Allen Parslow

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email



Loading...