Quantcast

timeline is not working properly in sonar 2.9

classic Classic list List threaded Threaded
16 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

timeline is not working properly in sonar 2.9

Vishnuvardhan P
Timeline plugin is not working in sonar 2.9

I have added timeline plugin extensions/plugin folder in sonar 2.9 directory and restarted the sonar server

In projects when i click timeline

A loading bar is keep on loading continously

Whether timeline plugin is supported in sonar 2.9

i am using sonar timeline plugin 1.2
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: timeline is not working properly in sonar 2.9

Olivier Gaudin-2
Hi,

What happens when you click here ?
http://nemo.sonarsource.org/plugins/resource/78577?page=org.sonar.plugins.timeline.GwtTimeline

Olivier


On Fri, Aug 5, 2011 at 10:44 AM, Vishnuvardhan P <[hidden email]> wrote:

Timeline plugin is not working in sonar 2.9

I have added timeline plugin extensions/plugin folder in sonar 2.9 directory
and restarted the sonar server

In projects when i click timeline

A loading bar is keep on loading continously

Whether timeline plugin is supported in sonar 2.9

i am using sonar timeline plugin 1.2

--
View this message in context: http://old.nabble.com/timeline-is-not-working-properly-in-sonar-2.9-tp32200545p32200545.html
Sent from the Sonar user mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email



Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: timeline is not working properly in sonar 2.9

John Broome
I hate to piggy-back on Vishnuvardhan's message but i have the same issue:
http://old.nabble.com/Sonar-2.8%2C-Timeline-plugin-1.2-hangs-at-%22loading...%22-td32133581.html#a32133931

Visiting your link Olivier shows the flash timeline graph and the
dropdown boxes at the top for me.
http://dl.dropbox.com/u/233065/nemo-sonar.png

Thanks to anyone for any insight or tips!



On Fri, Aug 5, 2011 at 09:05, Olivier Gaudin <[hidden email]> wrote:

> Hi,
> What happens when you click here ?
> http://nemo.sonarsource.org/plugins/resource/78577?page=org.sonar.plugins.timeline.GwtTimeline
>
> Olivier
>
>
> On Fri, Aug 5, 2011 at 10:44 AM, Vishnuvardhan P <[hidden email]>
> wrote:
>>
>> Timeline plugin is not working in sonar 2.9
>>
>> I have added timeline plugin extensions/plugin folder in sonar 2.9
>> directory
>> and restarted the sonar server
>>
>> In projects when i click timeline
>>
>> A loading bar is keep on loading continously
>>
>> Whether timeline plugin is supported in sonar 2.9
>>
>> i am using sonar timeline plugin 1.2
>>
>> --
>> View this message in context:
>> http://old.nabble.com/timeline-is-not-working-properly-in-sonar-2.9-tp32200545p32200545.html
>> Sent from the Sonar user mailing list archive at Nabble.com.
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: timeline is not working properly in sonar 2.9

Simon Brandhof
John, is your server secured with HTTPS ? In this case you have to upgrade to timeline 1.1.

On 5 August 2011 15:41, John Broome <[hidden email]> wrote:
I hate to piggy-back on Vishnuvardhan's message but i have the same issue:
http://old.nabble.com/Sonar-2.8%2C-Timeline-plugin-1.2-hangs-at-%22loading...%22-td32133581.html#a32133931

Visiting your link Olivier shows the flash timeline graph and the
dropdown boxes at the top for me.
http://dl.dropbox.com/u/233065/nemo-sonar.png

Thanks to anyone for any insight or tips!



On Fri, Aug 5, 2011 at 09:05, Olivier Gaudin <[hidden email]> wrote:
> Hi,
> What happens when you click here ?
> http://nemo.sonarsource.org/plugins/resource/78577?page=org.sonar.plugins.timeline.GwtTimeline
>
> Olivier
>
>
> On Fri, Aug 5, 2011 at 10:44 AM, Vishnuvardhan P <[hidden email]>
> wrote:
>>
>> Timeline plugin is not working in sonar 2.9
>>
>> I have added timeline plugin extensions/plugin folder in sonar 2.9
>> directory
>> and restarted the sonar server
>>
>> In projects when i click timeline
>>
>> A loading bar is keep on loading continously
>>
>> Whether timeline plugin is supported in sonar 2.9
>>
>> i am using sonar timeline plugin 1.2
>>
>> --
>> View this message in context:
>> http://old.nabble.com/timeline-is-not-working-properly-in-sonar-2.9-tp32200545p32200545.html
>> Sent from the Sonar user mailing list archive at Nabble.com.
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email



Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: timeline is not working properly in sonar 2.9

John Broome
Thanks for the reply Simon.

Nope, plain HTTP.  And we're using timeline 1.2 on sonar 2.8.



On Fri, Aug 5, 2011 at 10:48, Simon Brandhof
<[hidden email]> wrote:

> John, is your server secured with HTTPS ? In this case you have to upgrade
> to timeline 1.1.
>
> On 5 August 2011 15:41, John Broome <[hidden email]> wrote:
>>
>> I hate to piggy-back on Vishnuvardhan's message but i have the same issue:
>>
>> http://old.nabble.com/Sonar-2.8%2C-Timeline-plugin-1.2-hangs-at-%22loading...%22-td32133581.html#a32133931
>>
>> Visiting your link Olivier shows the flash timeline graph and the
>> dropdown boxes at the top for me.
>> http://dl.dropbox.com/u/233065/nemo-sonar.png
>>
>> Thanks to anyone for any insight or tips!
>>
>>
>>
>> On Fri, Aug 5, 2011 at 09:05, Olivier Gaudin <[hidden email]> wrote:
>> > Hi,
>> > What happens when you click here ?
>> >
>> > http://nemo.sonarsource.org/plugins/resource/78577?page=org.sonar.plugins.timeline.GwtTimeline
>> >
>> > Olivier
>> >
>> >
>> > On Fri, Aug 5, 2011 at 10:44 AM, Vishnuvardhan P
>> > <[hidden email]>
>> > wrote:
>> >>
>> >> Timeline plugin is not working in sonar 2.9
>> >>
>> >> I have added timeline plugin extensions/plugin folder in sonar 2.9
>> >> directory
>> >> and restarted the sonar server
>> >>
>> >> In projects when i click timeline
>> >>
>> >> A loading bar is keep on loading continously
>> >>
>> >> Whether timeline plugin is supported in sonar 2.9
>> >>
>> >> i am using sonar timeline plugin 1.2
>> >>
>> >> --
>> >> View this message in context:
>> >>
>> >> http://old.nabble.com/timeline-is-not-working-properly-in-sonar-2.9-tp32200545p32200545.html
>> >> Sent from the Sonar user mailing list archive at Nabble.com.
>> >>
>> >>
>> >> ---------------------------------------------------------------------
>> >> To unsubscribe from this list, please visit:
>> >>
>> >>    http://xircles.codehaus.org/manage_email
>> >>
>> >>
>> >
>> >
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: timeline is not working properly in sonar 2.9

Olivier Gaudin-2
John,

Given the fact that Nemo is running Sonar 2.9 and Timeline 1.2, this must be an issue with your client. The Timeline actually requires internet connectivity to access google site. Since you can see Nemo fine, I am wondering if this could be an issue with your proxy settings. When you browse your Sonar server, you are actually staying inside your company and probably not using company proxy. But the timeline needs external access which explains why you do not see anything. That would also explain wh you can see Nemo fine. Can you try to look in that direction ?

Olivier


On Fri, Aug 5, 2011 at 5:06 PM, John Broome <[hidden email]> wrote:
Thanks for the reply Simon.

Nope, plain HTTP.  And we're using timeline 1.2 on sonar 2.8.



On Fri, Aug 5, 2011 at 10:48, Simon Brandhof
<[hidden email]> wrote:
> John, is your server secured with HTTPS ? In this case you have to upgrade
> to timeline 1.1.
>
> On 5 August 2011 15:41, John Broome <[hidden email]> wrote:
>>
>> I hate to piggy-back on Vishnuvardhan's message but i have the same issue:
>>
>> http://old.nabble.com/Sonar-2.8%2C-Timeline-plugin-1.2-hangs-at-%22loading...%22-td32133581.html#a32133931
>>
>> Visiting your link Olivier shows the flash timeline graph and the
>> dropdown boxes at the top for me.
>> http://dl.dropbox.com/u/233065/nemo-sonar.png
>>
>> Thanks to anyone for any insight or tips!
>>
>>
>>
>> On Fri, Aug 5, 2011 at 09:05, Olivier Gaudin <[hidden email]> wrote:
>> > Hi,
>> > What happens when you click here ?
>> >
>> > http://nemo.sonarsource.org/plugins/resource/78577?page=org.sonar.plugins.timeline.GwtTimeline
>> >
>> > Olivier
>> >
>> >
>> > On Fri, Aug 5, 2011 at 10:44 AM, Vishnuvardhan P
>> > <[hidden email]>
>> > wrote:
>> >>
>> >> Timeline plugin is not working in sonar 2.9
>> >>
>> >> I have added timeline plugin extensions/plugin folder in sonar 2.9
>> >> directory
>> >> and restarted the sonar server
>> >>
>> >> In projects when i click timeline
>> >>
>> >> A loading bar is keep on loading continously
>> >>
>> >> Whether timeline plugin is supported in sonar 2.9
>> >>
>> >> i am using sonar timeline plugin 1.2
>> >>
>> >> --
>> >> View this message in context:
>> >>
>> >> http://old.nabble.com/timeline-is-not-working-properly-in-sonar-2.9-tp32200545p32200545.html
>> >> Sent from the Sonar user mailing list archive at Nabble.com.
>> >>
>> >>
>> >> ---------------------------------------------------------------------
>> >> To unsubscribe from this list, please visit:
>> >>
>> >>    http://xircles.codehaus.org/manage_email
>> >>
>> >>
>> >
>> >
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email



Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: timeline is not working properly in sonar 2.9

John Broome
Ah, now that's something I can track down.

AFAIK, there's no proxy settings between the server running sonar and
the greater internet.  Which subdomain on google does timeline talk
to?  api.google.com?  I'll try a wget from the sonar server and make
sure I can connect to *.google.com sites.

Thanks for a nudge in the right direction!



On Sat, Aug 6, 2011 at 11:27, Olivier Gaudin <[hidden email]> wrote:

> John,
> Given the fact that Nemo is running Sonar 2.9 and Timeline 1.2, this must be
> an issue with your client. The Timeline actually requires internet
> connectivity to access google site. Since you can see Nemo fine, I am
> wondering if this could be an issue with your proxy settings. When you
> browse your Sonar server, you are actually staying inside your company and
> probably not using company proxy. But the timeline needs external access
> which explains why you do not see anything. That would also explain wh you
> can see Nemo fine. Can you try to look in that direction ?
> Olivier
>
>
> On Fri, Aug 5, 2011 at 5:06 PM, John Broome <[hidden email]> wrote:
>>
>> Thanks for the reply Simon.
>>
>> Nope, plain HTTP.  And we're using timeline 1.2 on sonar 2.8.
>>
>>
>>
>> On Fri, Aug 5, 2011 at 10:48, Simon Brandhof
>> <[hidden email]> wrote:
>> > John, is your server secured with HTTPS ? In this case you have to
>> > upgrade
>> > to timeline 1.1.
>> >
>> > On 5 August 2011 15:41, John Broome <[hidden email]> wrote:
>> >>
>> >> I hate to piggy-back on Vishnuvardhan's message but i have the same
>> >> issue:
>> >>
>> >>
>> >> http://old.nabble.com/Sonar-2.8%2C-Timeline-plugin-1.2-hangs-at-%22loading...%22-td32133581.html#a32133931
>> >>
>> >> Visiting your link Olivier shows the flash timeline graph and the
>> >> dropdown boxes at the top for me.
>> >> http://dl.dropbox.com/u/233065/nemo-sonar.png
>> >>
>> >> Thanks to anyone for any insight or tips!
>> >>
>> >>
>> >>
>> >> On Fri, Aug 5, 2011 at 09:05, Olivier Gaudin <[hidden email]> wrote:
>> >> > Hi,
>> >> > What happens when you click here ?
>> >> >
>> >> >
>> >> > http://nemo.sonarsource.org/plugins/resource/78577?page=org.sonar.plugins.timeline.GwtTimeline
>> >> >
>> >> > Olivier
>> >> >
>> >> >
>> >> > On Fri, Aug 5, 2011 at 10:44 AM, Vishnuvardhan P
>> >> > <[hidden email]>
>> >> > wrote:
>> >> >>
>> >> >> Timeline plugin is not working in sonar 2.9
>> >> >>
>> >> >> I have added timeline plugin extensions/plugin folder in sonar 2.9
>> >> >> directory
>> >> >> and restarted the sonar server
>> >> >>
>> >> >> In projects when i click timeline
>> >> >>
>> >> >> A loading bar is keep on loading continously
>> >> >>
>> >> >> Whether timeline plugin is supported in sonar 2.9
>> >> >>
>> >> >> i am using sonar timeline plugin 1.2
>> >> >>
>> >> >> --
>> >> >> View this message in context:
>> >> >>
>> >> >>
>> >> >> http://old.nabble.com/timeline-is-not-working-properly-in-sonar-2.9-tp32200545p32200545.html
>> >> >> Sent from the Sonar user mailing list archive at Nabble.com.
>> >> >>
>> >> >>
>> >> >>
>> >> >> ---------------------------------------------------------------------
>> >> >> To unsubscribe from this list, please visit:
>> >> >>
>> >> >>    http://xircles.codehaus.org/manage_email
>> >> >>
>> >> >>
>> >> >
>> >> >
>> >>
>> >> ---------------------------------------------------------------------
>> >> To unsubscribe from this list, please visit:
>> >>
>> >>    http://xircles.codehaus.org/manage_email
>> >>
>> >>
>> >
>> >
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: timeline is not working properly in sonar 2.9

John Broome
In reply to this post by Olivier Gaudin-2
I compared firebug output on Nemo vs my server and saw that I'm not
even getting to the javascript that makes calls to google.com or
ajax.googleapis.com.

http://dl.dropbox.com/u/233065/sonar-timeline-noJS.png

I started firefox in safe mode with no adblock or noscript running and
was stuck in the same place.

i'm able to open
http://ajax.googleapis.com/ajax/static/modules/gviz/1.0/annotatedtimeline/annotatedtimeline.css
and google.com on the sonar server in w3m.

So strange.


On Sat, Aug 6, 2011 at 11:27, Olivier Gaudin <[hidden email]> wrote:

> John,
> Given the fact that Nemo is running Sonar 2.9 and Timeline 1.2, this must be
> an issue with your client. The Timeline actually requires internet
> connectivity to access google site. Since you can see Nemo fine, I am
> wondering if this could be an issue with your proxy settings. When you
> browse your Sonar server, you are actually staying inside your company and
> probably not using company proxy. But the timeline needs external access
> which explains why you do not see anything. That would also explain wh you
> can see Nemo fine. Can you try to look in that direction ?
> Olivier
>
>
> On Fri, Aug 5, 2011 at 5:06 PM, John Broome <[hidden email]> wrote:
>>
>> Thanks for the reply Simon.
>>
>> Nope, plain HTTP.  And we're using timeline 1.2 on sonar 2.8.
>>
>>
>>
>> On Fri, Aug 5, 2011 at 10:48, Simon Brandhof
>> <[hidden email]> wrote:
>> > John, is your server secured with HTTPS ? In this case you have to
>> > upgrade
>> > to timeline 1.1.
>> >
>> > On 5 August 2011 15:41, John Broome <[hidden email]> wrote:
>> >>
>> >> I hate to piggy-back on Vishnuvardhan's message but i have the same
>> >> issue:
>> >>
>> >>
>> >> http://old.nabble.com/Sonar-2.8%2C-Timeline-plugin-1.2-hangs-at-%22loading...%22-td32133581.html#a32133931
>> >>
>> >> Visiting your link Olivier shows the flash timeline graph and the
>> >> dropdown boxes at the top for me.
>> >> http://dl.dropbox.com/u/233065/nemo-sonar.png
>> >>
>> >> Thanks to anyone for any insight or tips!
>> >>
>> >>
>> >>
>> >> On Fri, Aug 5, 2011 at 09:05, Olivier Gaudin <[hidden email]> wrote:
>> >> > Hi,
>> >> > What happens when you click here ?
>> >> >
>> >> >
>> >> > http://nemo.sonarsource.org/plugins/resource/78577?page=org.sonar.plugins.timeline.GwtTimeline
>> >> >
>> >> > Olivier
>> >> >
>> >> >
>> >> > On Fri, Aug 5, 2011 at 10:44 AM, Vishnuvardhan P
>> >> > <[hidden email]>
>> >> > wrote:
>> >> >>
>> >> >> Timeline plugin is not working in sonar 2.9
>> >> >>
>> >> >> I have added timeline plugin extensions/plugin folder in sonar 2.9
>> >> >> directory
>> >> >> and restarted the sonar server
>> >> >>
>> >> >> In projects when i click timeline
>> >> >>
>> >> >> A loading bar is keep on loading continously
>> >> >>
>> >> >> Whether timeline plugin is supported in sonar 2.9
>> >> >>
>> >> >> i am using sonar timeline plugin 1.2
>> >> >>
>> >> >> --
>> >> >> View this message in context:
>> >> >>
>> >> >>
>> >> >> http://old.nabble.com/timeline-is-not-working-properly-in-sonar-2.9-tp32200545p32200545.html
>> >> >> Sent from the Sonar user mailing list archive at Nabble.com.
>> >> >>
>> >> >>
>> >> >>
>> >> >> ---------------------------------------------------------------------
>> >> >> To unsubscribe from this list, please visit:
>> >> >>
>> >> >>    http://xircles.codehaus.org/manage_email
>> >> >>
>> >> >>
>> >> >
>> >> >
>> >>
>> >> ---------------------------------------------------------------------
>> >> To unsubscribe from this list, please visit:
>> >>
>> >>    http://xircles.codehaus.org/manage_email
>> >>
>> >>
>> >
>> >
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: timeline is not working properly in sonar 2.9

Olivier Gaudin-2
In reply to this post by John Broome
The internet connexion is required from the client, not the server

Olivier


On Mon, Aug 8, 2011 at 3:03 PM, John Broome <[hidden email]> wrote:
Ah, now that's something I can track down.

AFAIK, there's no proxy settings between the server running sonar and
the greater internet.  Which subdomain on google does timeline talk
to?  api.google.com?  I'll try a wget from the sonar server and make
sure I can connect to *.google.com sites.

Thanks for a nudge in the right direction!



On Sat, Aug 6, 2011 at 11:27, Olivier Gaudin <[hidden email]> wrote:
> John,
> Given the fact that Nemo is running Sonar 2.9 and Timeline 1.2, this must be
> an issue with your client. The Timeline actually requires internet
> connectivity to access google site. Since you can see Nemo fine, I am
> wondering if this could be an issue with your proxy settings. When you
> browse your Sonar server, you are actually staying inside your company and
> probably not using company proxy. But the timeline needs external access
> which explains why you do not see anything. That would also explain wh you
> can see Nemo fine. Can you try to look in that direction ?
> Olivier
>
>
> On Fri, Aug 5, 2011 at 5:06 PM, John Broome <[hidden email]> wrote:
>>
>> Thanks for the reply Simon.
>>
>> Nope, plain HTTP.  And we're using timeline 1.2 on sonar 2.8.
>>
>>
>>
>> On Fri, Aug 5, 2011 at 10:48, Simon Brandhof
>> <[hidden email]> wrote:
>> > John, is your server secured with HTTPS ? In this case you have to
>> > upgrade
>> > to timeline 1.1.
>> >
>> > On 5 August 2011 15:41, John Broome <[hidden email]> wrote:
>> >>
>> >> I hate to piggy-back on Vishnuvardhan's message but i have the same
>> >> issue:
>> >>
>> >>
>> >> http://old.nabble.com/Sonar-2.8%2C-Timeline-plugin-1.2-hangs-at-%22loading...%22-td32133581.html#a32133931
>> >>
>> >> Visiting your link Olivier shows the flash timeline graph and the
>> >> dropdown boxes at the top for me.
>> >> http://dl.dropbox.com/u/233065/nemo-sonar.png
>> >>
>> >> Thanks to anyone for any insight or tips!
>> >>
>> >>
>> >>
>> >> On Fri, Aug 5, 2011 at 09:05, Olivier Gaudin <[hidden email]> wrote:
>> >> > Hi,
>> >> > What happens when you click here ?
>> >> >
>> >> >
>> >> > http://nemo.sonarsource.org/plugins/resource/78577?page=org.sonar.plugins.timeline.GwtTimeline
>> >> >
>> >> > Olivier
>> >> >
>> >> >
>> >> > On Fri, Aug 5, 2011 at 10:44 AM, Vishnuvardhan P
>> >> > <[hidden email]>
>> >> > wrote:
>> >> >>
>> >> >> Timeline plugin is not working in sonar 2.9
>> >> >>
>> >> >> I have added timeline plugin extensions/plugin folder in sonar 2.9
>> >> >> directory
>> >> >> and restarted the sonar server
>> >> >>
>> >> >> In projects when i click timeline
>> >> >>
>> >> >> A loading bar is keep on loading continously
>> >> >>
>> >> >> Whether timeline plugin is supported in sonar 2.9
>> >> >>
>> >> >> i am using sonar timeline plugin 1.2
>> >> >>
>> >> >> --
>> >> >> View this message in context:
>> >> >>
>> >> >>
>> >> >> http://old.nabble.com/timeline-is-not-working-properly-in-sonar-2.9-tp32200545p32200545.html
>> >> >> Sent from the Sonar user mailing list archive at Nabble.com.
>> >> >>
>> >> >>
>> >> >>
>> >> >> ---------------------------------------------------------------------
>> >> >> To unsubscribe from this list, please visit:
>> >> >>
>> >> >>    http://xircles.codehaus.org/manage_email
>> >> >>
>> >> >>
>> >> >
>> >> >
>> >>
>> >> ---------------------------------------------------------------------
>> >> To unsubscribe from this list, please visit:
>> >>
>> >>    http://xircles.codehaus.org/manage_email
>> >>
>> >>
>> >
>> >
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email



Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: timeline is not working properly in sonar 2.9

Olivier Gaudin-2
In reply to this post by John Broome
Hi John,

I have to say that I am a bit stuck with your issue. Can you try from a different machine ? Different browser ?

Olivier


On Mon, Aug 8, 2011 at 9:27 PM, John Broome <[hidden email]> wrote:
I compared firebug output on Nemo vs my server and saw that I'm not
even getting to the javascript that makes calls to google.com or
ajax.googleapis.com.

http://dl.dropbox.com/u/233065/sonar-timeline-noJS.png

I started firefox in safe mode with no adblock or noscript running and
was stuck in the same place.

i'm able to open
http://ajax.googleapis.com/ajax/static/modules/gviz/1.0/annotatedtimeline/annotatedtimeline.css
and google.com on the sonar server in w3m.

So strange.


On Sat, Aug 6, 2011 at 11:27, Olivier Gaudin <[hidden email]> wrote:
> John,
> Given the fact that Nemo is running Sonar 2.9 and Timeline 1.2, this must be
> an issue with your client. The Timeline actually requires internet
> connectivity to access google site. Since you can see Nemo fine, I am
> wondering if this could be an issue with your proxy settings. When you
> browse your Sonar server, you are actually staying inside your company and
> probably not using company proxy. But the timeline needs external access
> which explains why you do not see anything. That would also explain wh you
> can see Nemo fine. Can you try to look in that direction ?
> Olivier
>
>
> On Fri, Aug 5, 2011 at 5:06 PM, John Broome <[hidden email]> wrote:
>>
>> Thanks for the reply Simon.
>>
>> Nope, plain HTTP.  And we're using timeline 1.2 on sonar 2.8.
>>
>>
>>
>> On Fri, Aug 5, 2011 at 10:48, Simon Brandhof
>> <[hidden email]> wrote:
>> > John, is your server secured with HTTPS ? In this case you have to
>> > upgrade
>> > to timeline 1.1.
>> >
>> > On 5 August 2011 15:41, John Broome <[hidden email]> wrote:
>> >>
>> >> I hate to piggy-back on Vishnuvardhan's message but i have the same
>> >> issue:
>> >>
>> >>
>> >> http://old.nabble.com/Sonar-2.8%2C-Timeline-plugin-1.2-hangs-at-%22loading...%22-td32133581.html#a32133931
>> >>
>> >> Visiting your link Olivier shows the flash timeline graph and the
>> >> dropdown boxes at the top for me.
>> >> http://dl.dropbox.com/u/233065/nemo-sonar.png
>> >>
>> >> Thanks to anyone for any insight or tips!
>> >>
>> >>
>> >>
>> >> On Fri, Aug 5, 2011 at 09:05, Olivier Gaudin <[hidden email]> wrote:
>> >> > Hi,
>> >> > What happens when you click here ?
>> >> >
>> >> >
>> >> > http://nemo.sonarsource.org/plugins/resource/78577?page=org.sonar.plugins.timeline.GwtTimeline
>> >> >
>> >> > Olivier
>> >> >
>> >> >
>> >> > On Fri, Aug 5, 2011 at 10:44 AM, Vishnuvardhan P
>> >> > <[hidden email]>
>> >> > wrote:
>> >> >>
>> >> >> Timeline plugin is not working in sonar 2.9
>> >> >>
>> >> >> I have added timeline plugin extensions/plugin folder in sonar 2.9
>> >> >> directory
>> >> >> and restarted the sonar server
>> >> >>
>> >> >> In projects when i click timeline
>> >> >>
>> >> >> A loading bar is keep on loading continously
>> >> >>
>> >> >> Whether timeline plugin is supported in sonar 2.9
>> >> >>
>> >> >> i am using sonar timeline plugin 1.2
>> >> >>
>> >> >> --
>> >> >> View this message in context:
>> >> >>
>> >> >>
>> >> >> http://old.nabble.com/timeline-is-not-working-properly-in-sonar-2.9-tp32200545p32200545.html
>> >> >> Sent from the Sonar user mailing list archive at Nabble.com.
>> >> >>
>> >> >>
>> >> >>
>> >> >> ---------------------------------------------------------------------
>> >> >> To unsubscribe from this list, please visit:
>> >> >>
>> >> >>    http://xircles.codehaus.org/manage_email
>> >> >>
>> >> >>
>> >> >
>> >> >
>> >>
>> >> ---------------------------------------------------------------------
>> >> To unsubscribe from this list, please visit:
>> >>
>> >>    http://xircles.codehaus.org/manage_email
>> >>
>> >>
>> >
>> >
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email



Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: timeline is not working properly in sonar 2.9

John Broome
Just tried on IE 8 on win 7 64bit and it threw this error up:

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64;
Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR
3.0.30729; Media Center PC 6.0; CMDTDF)
Timestamp: Mon, 8 Aug 2011 21:55:49 UTC


Message: 'a.a' is null or not an object
Line: 1222
Char: 78
Code: 0
URI: http://foobar.org/sonar/deploy/gwt/org.sonar.plugins.timeline.GwtTimeline/EA30241DBBF560E2A6E06EB07BA67C5C.cache.html


Message: Object doesn't support this property or method
Line: 1
Char: 1
Code: 0
URI: http://foobar.org/sonar/api/metrics?format=json&callback=callback1

firefox 5 hangs at loading...

Chrome 12 hangs at loading...

Chrome beta and FF5 on fedora 15 64bit hang at loading. . .

Motion chart shows up fine everywhere.

On Mon, Aug 8, 2011 at 17:49, Olivier Gaudin <[hidden email]> wrote:

> Hi John,
> I have to say that I am a bit stuck with your issue. Can you try from a
> different machine ? Different browser ?
>
> Olivier
>
>
> On Mon, Aug 8, 2011 at 9:27 PM, John Broome <[hidden email]> wrote:
>>
>> I compared firebug output on Nemo vs my server and saw that I'm not
>> even getting to the javascript that makes calls to google.com or
>> ajax.googleapis.com.
>>
>> http://dl.dropbox.com/u/233065/sonar-timeline-noJS.png
>>
>> I started firefox in safe mode with no adblock or noscript running and
>> was stuck in the same place.
>>
>> i'm able to open
>>
>> http://ajax.googleapis.com/ajax/static/modules/gviz/1.0/annotatedtimeline/annotatedtimeline.css
>> and google.com on the sonar server in w3m.
>>
>> So strange.
>>
>>
>> On Sat, Aug 6, 2011 at 11:27, Olivier Gaudin <[hidden email]> wrote:
>> > John,
>> > Given the fact that Nemo is running Sonar 2.9 and Timeline 1.2, this
>> > must be
>> > an issue with your client. The Timeline actually requires internet
>> > connectivity to access google site. Since you can see Nemo fine, I am
>> > wondering if this could be an issue with your proxy settings. When you
>> > browse your Sonar server, you are actually staying inside your company
>> > and
>> > probably not using company proxy. But the timeline needs external access
>> > which explains why you do not see anything. That would also explain wh
>> > you
>> > can see Nemo fine. Can you try to look in that direction ?
>> > Olivier
>> >
>> >
>> > On Fri, Aug 5, 2011 at 5:06 PM, John Broome <[hidden email]> wrote:
>> >>
>> >> Thanks for the reply Simon.
>> >>
>> >> Nope, plain HTTP.  And we're using timeline 1.2 on sonar 2.8.
>> >>
>> >>
>> >>
>> >> On Fri, Aug 5, 2011 at 10:48, Simon Brandhof
>> >> <[hidden email]> wrote:
>> >> > John, is your server secured with HTTPS ? In this case you have to
>> >> > upgrade
>> >> > to timeline 1.1.
>> >> >
>> >> > On 5 August 2011 15:41, John Broome <[hidden email]> wrote:
>> >> >>
>> >> >> I hate to piggy-back on Vishnuvardhan's message but i have the same
>> >> >> issue:
>> >> >>
>> >> >>
>> >> >>
>> >> >> http://old.nabble.com/Sonar-2.8%2C-Timeline-plugin-1.2-hangs-at-%22loading...%22-td32133581.html#a32133931
>> >> >>
>> >> >> Visiting your link Olivier shows the flash timeline graph and the
>> >> >> dropdown boxes at the top for me.
>> >> >> http://dl.dropbox.com/u/233065/nemo-sonar.png
>> >> >>
>> >> >> Thanks to anyone for any insight or tips!
>> >> >>
>> >> >>
>> >> >>
>> >> >> On Fri, Aug 5, 2011 at 09:05, Olivier Gaudin <[hidden email]>
>> >> >> wrote:
>> >> >> > Hi,
>> >> >> > What happens when you click here ?
>> >> >> >
>> >> >> >
>> >> >> >
>> >> >> > http://nemo.sonarsource.org/plugins/resource/78577?page=org.sonar.plugins.timeline.GwtTimeline
>> >> >> >
>> >> >> > Olivier
>> >> >> >
>> >> >> >
>> >> >> > On Fri, Aug 5, 2011 at 10:44 AM, Vishnuvardhan P
>> >> >> > <[hidden email]>
>> >> >> > wrote:
>> >> >> >>
>> >> >> >> Timeline plugin is not working in sonar 2.9
>> >> >> >>
>> >> >> >> I have added timeline plugin extensions/plugin folder in sonar
>> >> >> >> 2.9
>> >> >> >> directory
>> >> >> >> and restarted the sonar server
>> >> >> >>
>> >> >> >> In projects when i click timeline
>> >> >> >>
>> >> >> >> A loading bar is keep on loading continously
>> >> >> >>
>> >> >> >> Whether timeline plugin is supported in sonar 2.9
>> >> >> >>
>> >> >> >> i am using sonar timeline plugin 1.2
>> >> >> >>
>> >> >> >> --
>> >> >> >> View this message in context:
>> >> >> >>
>> >> >> >>
>> >> >> >>
>> >> >> >> http://old.nabble.com/timeline-is-not-working-properly-in-sonar-2.9-tp32200545p32200545.html
>> >> >> >> Sent from the Sonar user mailing list archive at Nabble.com.
>> >> >> >>
>> >> >> >>
>> >> >> >>
>> >> >> >>
>> >> >> >> ---------------------------------------------------------------------
>> >> >> >> To unsubscribe from this list, please visit:
>> >> >> >>
>> >> >> >>    http://xircles.codehaus.org/manage_email
>> >> >> >>
>> >> >> >>
>> >> >> >
>> >> >> >
>> >> >>
>> >> >>
>> >> >> ---------------------------------------------------------------------
>> >> >> To unsubscribe from this list, please visit:
>> >> >>
>> >> >>    http://xircles.codehaus.org/manage_email
>> >> >>
>> >> >>
>> >> >
>> >> >
>> >>
>> >> ---------------------------------------------------------------------
>> >> To unsubscribe from this list, please visit:
>> >>
>> >>    http://xircles.codehaus.org/manage_email
>> >>
>> >>
>> >
>> >
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: timeline is not working properly in sonar 2.9

Dean Aldinger
In reply to this post by Olivier Gaudin-2
We were having the same issue. In inspecting the json returned I
discovered that there was a manual metric named "Test"
with no description.

After deleting that manual metric from configuration
then the timeline worked as expected.

Olivier Gaudin-2 wrote
Hi,

What happens when you click here ?
http://nemo.sonarsource.org/plugins/resource/78577?page=org.sonar.plugins.timeline.GwtTimeline

Olivier


On Fri, Aug 5, 2011 at 10:44 AM, Vishnuvardhan P
<vishnu.vis2007@gmail.com>wrote:

>
> Timeline plugin is not working in sonar 2.9
>
> I have added timeline plugin extensions/plugin folder in sonar 2.9
> directory
> and restarted the sonar server
>
> In projects when i click timeline
>
> A loading bar is keep on loading continously
>
> Whether timeline plugin is supported in sonar 2.9
>
> i am using sonar timeline plugin 1.2
>
> --
> View this message in context:
> http://old.nabble.com/timeline-is-not-working-properly-in-sonar-2.9-tp32200545p32200545.html
> Sent from the Sonar user mailing list archive at Nabble.com.
>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: timeline is not working properly in sonar 2.9

Freddy Mallet SonarSource
Well done Dean ! I've managed to reproduce this issue locally (http://jira.codehaus.org/browse/SONARPLUGINS-1364). 

Indeed the problem occurs as soon as a new manual metric is created.

----------------------------------------
Freddy Mallet
www.SonarSource.org
www.SonarSource.com
----------------------------------------


On Thu, Sep 8, 2011 at 11:31 PM, Dean Aldinger <[hidden email]> wrote:

We were having the same issue. In inspecting the json returned I
discovered that there was a manual metric named "Test"
with no description.

After deleting that manual metric from configuration
then the timeline worked as expected.


Olivier Gaudin-2 wrote:
>
> Hi,
>
> What happens when you click here ?
> http://nemo.sonarsource.org/plugins/resource/78577?page=org.sonar.plugins.timeline.GwtTimeline
>
> Olivier
>
>
> On Fri, Aug 5, 2011 at 10:44 AM, Vishnuvardhan P
> <[hidden email]>wrote:
>
>>
>> Timeline plugin is not working in sonar 2.9
>>
>> I have added timeline plugin extensions/plugin folder in sonar 2.9
>> directory
>> and restarted the sonar server
>>
>> In projects when i click timeline
>>
>> A loading bar is keep on loading continously
>>
>> Whether timeline plugin is supported in sonar 2.9
>>
>> i am using sonar timeline plugin 1.2
>>
>> --
>> View this message in context:
>> http://old.nabble.com/timeline-is-not-working-properly-in-sonar-2.9-tp32200545p32200545.html
>> Sent from the Sonar user mailing list archive at Nabble.com.
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>>
>
>

--
View this message in context: http://old.nabble.com/timeline-is-not-working-properly-in-sonar-2.9-tp32200545p32427286.html
Sent from the Sonar user mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email



Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: timeline is not working properly in sonar 2.9

Jorge Costa
Hi,

Is this issue in the pipeline to be solve any time soon.... Started getting problems after the suggestion in this thread:

http://sonar.15.n6.nabble.com/Create-a-filter-to-display-only-specified-projects-td5000274.html

Jorge Costa
Best Regards
Jorge Costa
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: timeline is not working properly in sonar 2.9

Freddy Mallet
Hi Jorge,

I've scheduled version 1.2.1 of the TimeLine plugin for the end of august.

-----
Sonar for Continuous Inspection



On Sat, Jun 30, 2012 at 7:45 PM, jmecosta <[hidden email]> wrote:
Hi,

Is this issue in the pipeline to be solve any time soon.... Started getting
problems after the suggestion in this thread:

http://sonar.15.n6.nabble.com/Create-a-filter-to-display-only-specified-projects-td5000274.html

Jorge Costa

--
View this message in context: http://sonar.15.n6.nabble.com/timeline-is-not-working-properly-in-sonar-2-9-tp3160815p5000456.html
Sent from the Sonar user mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email



Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: timeline is not working properly in sonar 2.9

Jorge Costa
thats good, thanks

JC
Best Regards
Jorge Costa
Loading...